Facebook Business Product Feed Issues

Hi there,

We’re having two issues with using the RSS feed to import to a Facebook Business Catalogue. One is a minor issue, but the second is a bit more significant and only recently appears to have occurred.

We’ve had this first issue since we first set up the catalogue with the data feed. It doesn’t prevent anything from working, but is a small annoyance that the rss doesn’t appear to contain all of the necessary information:

Category-related field missing: “size”, “google_product_category” in Spreadshirt link
For items in the 212 category, a value should be provided for size,google_product_category.

Previously the shop was up and running with the products showing up in the shop despite the issue above, however at some point recently, the shop has stopped displaying on the Facebook Page. Upon checking the business manager it appears to be down to a new issue, preventing the products showing in the shop:

Universal IDs are missing: “gtin”, “mpn”, “brand” in Spreadshirt link
Products need one of the following universal identifiers to run in ads:– Global Trade Item Number (GTIN) – Manufacturer part number (MPN) – Brand name.Include one of these universal identifiers for each product in your data feed file and upload it again.

Both issues affect every item in our shop. Can anyone shed some light on any reasons or solutions?

Hello there!

Sorry for my late reply, but it took me some time to investigate regarding this behavior on FB’s side.
I needed to retry all possible steps to see if I can reproduce that scenario.

Anyway, it is not intented to populate the feed with size informations due to the technical aspects and the feed service.

I know how bad Google and FB love to request size informations while at the same time they are not treatening them as a critical requirement.
Search results and campaign related usecases are not affected by missing size attributes within a feed.
Or to use your words:

Regarding the google_product_category:
It is already included in the feed and can be found in the product details.
In this example it is: 5608
If you want to check on your own, I´d suggest to take a look at the product list within FB business manager, click on the dedicated product and chose the “view more” button. Then this window opens:

This seems to be something apart from the intendet feed upload behavior, as we are definately sending those attributes, as seen in the screenshot above.
But to clarify this in detail, I need some additional informations from your side. If you can provide any links (to your FB Shop) or Screenshots, Error Reports etc. this would be super helpful for us. :slight_smile:

Regarding the size, it looks like the google_product_category is showing fine, which implies it’s just Facebook complaining the size info isn’t there?

Issue is on this screenshot either way.

The second issue isn’t occurring when uploading a feed any more, but I think something’s still going wrong considering at the top it says 0 products in this data feed despite the upload session stating 27 items updated. The items are still not appearing in the Page’s shop, which they were previously.

Here’s what the error messages were at the time:

Interestingly enough, despite the products no longer showing in the Facebook shop, we do still have the ability to use Instagram shopping to tag products in the catalogue.

Yes, there is no size info within our feed. This is intented from our side, to keep the feed creation server response time low and to not overload the feed for shops with A LOT products.

Your recent screenshot (first one from above) is identic to what I experience on a daily base, with regards to the warning messages. Therefore I´d say it is correct and working :+1:

If products are not showing up in time, this might be related to a synch problem at FB’s side. The feed file is correct. FB processes the text data and turns it into “clickable items” within their dashboards & shops.
I’d say though FB has released the Feed functionality, it is not 100% working properly yet.
It`s basic functionality is there, but there are a lot of exceptions and UX/UI flaws.

You will also experience that some of your products get stuck in " to be processed" status for ever.
That is something you´ll need to deal with. So you´ll be probably never ever be able to list your assortment completely.
But from a conversion point of view, this is nothing to impact your success as a seller in general.

[Update] Size Attribute now available!

Today we have released a new version of the Product Feed. It contains the often requested “size-attribute”. :sparkles:
We deliver one default size for all qualified articles. Unisize Products and accessoires are excluded from that case.

By re-fetching your feed from scratch, the changes apply immediately and the “size” attribute is available for Google Merchant Center and FB’s Business Manager.

Your Feedback is welcome and appreciated.

1 Like

I’ve just checked this and the size attribute column appears to be working as expected now. It’s not flagging as an issue now, and upon inspecting a product I can see a size listed.


I’ve added some new products to the Spreadshirt Shop since last discussing, and I’m now having the other issue occurring again:
Some products can’t be used in the shop section of your Facebook Page due to the following errors: Universal IDs are missing: gtin, mpn, brand

Strangely this is only affecting the newly added products, not the older ones.

The older products are now showing in the Facebook shop (not sure exactly when they reappeared), although the newly added ones are not. Both lots can be used to tag on instagram shopping.

I’m assuming Facebook will sort itself out again with time, but I thought I’d mention it in case it helps shed any light on the issue.

hey there!
Many thanks for checking out the latest feed version an your feedback! It´s important for us to get some insights where blockers may still occur.

I have reproduced the upload with your shop feed but I could not find any issues with the data. Even FB did not claim any of the products details. Have you tried to reprocess the feed one more time?
Otherwise I´d need some more data, like, which articles have been reported in detail?

Hey Thomas,

Have just tried again but seeing the same thing.

Here’s what’s coming up.

There are 38 newly added products, so it appears to be those which are causing issues. In the 5 examples Facebook shows there are 4 different product types, so it doesn’t seem related to specific items.

There is also a csv file generated and sent by email, but it shows more or less the same details. Not sure what other information to share - Facebook isn’t the most transparent with these things.

Allright. That´s a bit tricky. Therefore I have forwarded it to our developers.
I´ll keep your updated about the outcome!

1 Like

Hello! Any updates on the issue about missing brand, gtin, mpn? Facing this issue at the moment…

whoop that went under my radar.
Can you send me your feed URL via private message?
I cannot confirm this issue with example feeds I have.

@roomjs did you try to add a custom column in your feed with “identifier exists” and just put “no” ?